Excel - Nella funzione CERCA.VERT come indicare la colonna di ricerca?

Basandoci sui dati di una tabella simile alla seguente, ma eventualmente anche con molte colonne in più, vogliamo sapere qual è la sede di un certo dipendente, di cui conosciamo il cognome.

tabella Excel per CERCA.VERT

A tal proposito nella cella in cui vogliamo collocare il risultato impostiamo la funzione CERCA.VERT (VLOOKUP) di Excel nella quale indichiamo:

  • nel primo parametro il valore da cercare (per esempio "Ruscelli")
  • nel secondo parametro l'intervallo di celle in cui eseguire la ricerca, definito in modo tale da contenere nella prima colonna il valore da cercare (nel nostro caso B2:F6)
  • nel terzo parametro il numero della colonna in cui si trova il risultato desiderato, a partire dalla prima all'interno dell'intervallo di ricerca, quindi  B2:F6 (potremmo indicare direttamente il numero 5)
  • nel quarto parametro il valore 0 perché vogliamo effettuare una ricerca precisa e non approssimata.

La funzione è quindi la seguente:

=CERCA.VERT("Ruscelli";B2:F6;5;0)

Se però, soprattutto nel caso di tabelle con molte colonne, preferiamo indicare l'intestazione della colonna (sede) e non il numero, possiamo ricorre alla funzione CONFRONTA, che fornisce la posizione occupata dal testo "sede" nella matrice delle intestazioni relative alla tabella di ricerca.

Quindi la formula finale, in cui innestiamo la funzione CONTRONTA nella CERCA.VERT, è la seguente:

=CERCA.VERT("Ruscelli";B2:F6;CONFRONTA("sede";B1:F1;0);0)

Nella cella in cui abbiamo impostato la funzione otterremo il seguente risultato: Milano.